Compatibility Matrix

When choosing a Rasa X version to install or update to, refer to the table below to help choose the compatible Rasa Open Source and Rasa SDK versions.

It is recommended to always use the latest PATCH version of whatever MINOR version you’re on, because it introduces bug fixes without any breaking changes. (See Semantic Versioning)

Rasa X Rasa Open Source Rasa SDK
0.28.x 1.10.x 1.10.x
0.27.8 1.9.7 1.9.0
0.26.4 1.8.3 1.8.1
0.25.3 1.7.4 1.7.0
0.24.8 1.6.2 1.6.1
0.23.6 1.5.3 1.5.2
0.22.2 1.4.6 1.4.0
0.21.5 1.3.10 1.3.3
0.20.5 1.2.9 1.2.0

Semantic Versioning

Rasa X, Rasa Open Source and Rasa SDK adhere to Semantic Versioning:

The values for a given a version number MAJOR.MINOR.PATCH are incremented as follows:

  • MAJOR version for incompatible API changes
  • MINOR version for functionality added in a backwards compatible manner
  • PATCH version for backwards compatible bug fixes.